Skip to content

[Bug]: Webtop not resolving DNS with custom DNSDomain #164

Description

@certanet

Holorouter Version

9.1

VCF Version

VCF 9.1

Target Type

vCenter Cluster

Describe the bug

When providing a custom domain with the -DNSDomain flag to New-HoloDeckInstance, the deployment works fine, but the Holorouter Webtop interface doesn't resolve any of the FQDNs. Lookups from external sources work correctly, as does internal product-to-product lookups, just Webtop it seems doesn't.
Accessing by IP is fine, so connectivity is there, but vCenter specifically redirects to the FQDN (which fails).
Using curl in webtop also fails to resolve.

Reproduction steps

  1. Deploy a 9.1 instance with the -DNSDomain flag set
  2. Wait for full deployment
  3. Try to access the FQDN of any of the deployed components

Expected behavior

The FQDN is resolved and connectivity to the product works.

Relevant logs

Additional context

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

bugSomething isn't working

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions