Skip to content
Merged
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension


Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
8 changes: 8 additions & 0 deletions .changeset/eve-extension-rebuild-eve-0-90.md
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
---
"@upstash/agentkit-eve-extension": minor
"@upstash/agentkit-eve": patch
---

Rebuild the eve extension on eve 0.91.0 and raise its `eve` peer floor to `>=0.91.0`. The manifest records the eve version the dist was built with, and eve 0.90.x and older refuse a dist built with 0.91.0 ("was built with eve 0.91.0. Upgrade eve to 0.91.0 or later"), so the previous `>=0.85.0` floor admitted versions that fail at `eve build`.

Both `eve` peer ranges now also admit eve 1.0 prereleases (`|| >=1.0.0-0`). semver never matches a prerelease against `>=0.x`, so `npm install eve@latest` (now `1.0.0-rc.1`) failed with ERESOLVE against `@upstash/agentkit-eve` and `@upstash/agentkit-eve-extension`. A dist built on 0.91.0 builds cleanly on `eve@1.0.0-rc.1`.
1 change: 1 addition & 0 deletions CLAUDE.md
Original file line number Diff line number Diff line change
Expand Up @@ -1693,3 +1693,4 @@ find node_modules -path "*/zod/package.json" | while read f; do echo "$f $(node
need_tools/replay loop), Redis `SandboxInstanceStore`/`SandboxCheckpointStore` (+ Upstash Blob
`BlobStore`), QStash-backed background runs writing to `upstashStream`, and a QStash schedule for
`reapDetachedRuns`.
- **eve 0.91.0 + ai 7.0.159 (2026-10-31):** `eve ^0.91.0` / `ai 7.0.159` everywhere; the eve-extension dist is rebuilt on 0.91.0 (manifest `builtWithEve: 0.91.0`) and its `eve` peer floor is `>=0.91.0 || >=1.0.0-0` — verified by packing the 0.91.0-built dist into consumers: eve 0.90.0 refuses it (`was built with eve 0.91.0. Upgrade eve to 0.91.0 or later`), 0.91.0 and `1.0.0-rc.1` build clean. Both eve peers carry `|| >=1.0.0-0` because semver never matches a prerelease against `>=0.x`: `npm install eve@latest` (`1.0.0-rc.1`) failed ERESOLVE against the published `@upstash/agentkit-eve@0.18.0` (`peer eve@">=0.87.0"`). **Not adopted:** `eve@1.0.0-rc.1` (a dist built on it stamps `builtWithEve: 1.0.0-rc.1` and would refuse every 0.x eve, so build on stable) and **TanStack AI 1.0** (`@tanstack/ai` 1.0.1, `-persistence` 1.0.1, `-memory` 1.0.0): `chat()` now requires `threadId` and `ArtifactRecord` requires `blobKey`, so `packages/tanstack-ai` test files fail `tsc` and the middleware tests throw `chat() needs a threadId` (source + build are fine); pins stay on 0.71.0 / 0.10.1 / 0.2.16.
2 changes: 1 addition & 1 deletion examples/ai-sdk-demo/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
"@upstash/agentkit-ai-sdk": "workspace:*",
"@upstash/agentkit-sdk": "workspace:*",
"@upstash/redis": "^1.38.4",
"ai": "7.0.156",
"ai": "7.0.159",
"dotenv": "^16.4.5",
"next": "16.2.9",
"react": "19.2.6",
Expand Down
4 changes: 2 additions & 2 deletions examples/eve-demo/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -28,11 +28,11 @@
"@upstash/box": "^0.7.5",
"@upstash/redis": "^1.38.4",
"@vercel/connect": "2.5.6",
"ai": "7.0.156",
"ai": "7.0.159",
"class-variance-authority": "0.7.1",
"clsx": "2.1.1",
"cmdk": "1.1.1",
"eve": "^0.87.0",
"eve": "^0.91.0",
"lucide-react": "1.16.0",
"motion": "12.40.0",
"nanoid": "5.1.11",
Expand Down
4 changes: 2 additions & 2 deletions examples/eve-extension-demo/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -18,8 +18,8 @@
"@upstash/agentkit-eve-extension": "workspace:*",
"@upstash/redis": "^1.38.4",
"@vercel/connect": "2.5.6",
"ai": "7.0.156",
"eve": "^0.85.0",
"ai": "7.0.159",
"eve": "^0.91.0",
"zod": "4.4.3"
},
"devDependencies": {
Expand Down
2 changes: 1 addition & 1 deletion examples/mcp-toolkit-demo/next-env.d.ts
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
/// <reference types="next" />
/// <reference types="next/image-types/global" />
import "./.next/dev/types/routes.d.ts";
import "./.next/types/routes.d.ts";

// NOTE: This file should not be edited
// see https://nextjs.org/docs/app/api-reference/config/typescript for more information.
2 changes: 1 addition & 1 deletion packages/ai-sdk/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -53,7 +53,7 @@
"@ai-sdk/openai": "^4.0.71",
"@ai-sdk/provider": "^4.0.17",
"@upstash/redis": "^1.38.4",
"ai": "7.0.156",
"ai": "7.0.159",
"dotenv": "^16.4.5"
},
"peerDependencies": {
Expand Down
2 changes: 1 addition & 1 deletion packages/eve-extension/AGENTS.md
Original file line number Diff line number Diff line change
Expand Up @@ -37,7 +37,7 @@ unavailable, use https://eve.dev/docs/extensions as a fallback.
agent-shaped source tree into `dist/extension/`, emits type declarations and a
compatibility manifest, and fills the package `exports` map. Ship `dist/` only.
`eve` is a required peer so the consumer's eve is the one that runs, but NOT a
wildcard: keep the floor (`>=0.85.0`) in sync with what the built manifest's
wildcard: keep the floor (`>=0.91.0`) in sync with what the built manifest's
contracts require, so an incompatible eve fails at install instead of at
`eve build` (see issue #22). eve validates the real compatibility from the
generated manifest.
2 changes: 1 addition & 1 deletion packages/eve-extension/README.md
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ no repeated schemas; upgrades come through the package manager.

`<ns>` is the mount file's basename — the examples below use `agentkit`.

Start from an eve project (eve ≥ 0.85.0 — the prebuilt extension is built with eve 0.85.0, and eve 0.84+ checks the version an extension was built with against its own: 0.84.x and older refuse a dist built with 0.85.0; the package declares this as its `eve` peer range), then:
Start from an eve project (eve ≥ 0.91.0 (or a 1.0 prerelease) — the prebuilt extension is built with eve 0.91.0, and eve 0.84+ checks the version an extension was built with against its own: 0.90.x and older refuse a dist built with 0.91.0; the package declares this as its `eve` peer range), then:

```bash
pnpm add @upstash/agentkit-eve-extension
Expand Down
4 changes: 2 additions & 2 deletions packages/eve-extension/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -56,10 +56,10 @@
},
"devDependencies": {
"@types/node": "24.x",
"eve": "^0.85.0",
"eve": "^0.91.0",
"typescript": "7.0.2"
},
"peerDependencies": {
"eve": ">=0.85.0"
"eve": ">=0.91.0 || >=1.0.0-0"
}
}
6 changes: 3 additions & 3 deletions packages/eve/package.json
Original file line number Diff line number Diff line change
Expand Up @@ -60,14 +60,14 @@
"devDependencies": {
"@upstash/box": "^0.7.5",
"@upstash/redis": "^1.38.4",
"ai": "7.0.156",
"ai": "7.0.159",
"dotenv": "^16.4.5",
"eve": "^0.87.0"
"eve": "^0.91.0"
},
"peerDependencies": {
"@upstash/box": ">=0.7.1",
"@upstash/redis": ">=1.38.4",
"eve": ">=0.87.0"
"eve": ">=0.87.0 || >=1.0.0-0"
},
"peerDependenciesMeta": {
"@upstash/box": {
Expand Down
Loading
Loading