Repository navigation
Bump local Milvus to v3.0.3 and Faraday to 2.8.1 - #26
Merged
Merged
Conversation
- docker-compose: Milvus v2.4.5 -> v3.0.3, etcd v3.5.25, milvusdb/minio, add milvus-volume-init (v3.0 runs as non-root), align with the official v3.0.3 standalone compose file - Faraday 2.7.10 -> 2.15.0 (removes Ruby 3.4 base64 warning)
Faraday 2.9+ requires Ruby >= 3.0, which broke the 2.7 CI job. 2.8.1 is the newest release supporting Ruby >= 2.6 and depends on the base64 gem, which also removes the Ruby 3.4 base64 warning.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
milvusdb/minioimagemilvus-volume-initservice, because Milvus 3.0 runs as non-rootmc readyhealth check for MinIOMINIO_REGIONsetbase64gem, which removes the Ruby 3.4base64warning. The gemspec constraint (< 3) is unchanged.Testing
rspec: 46 examples, 0 failuresNotes
volumes/data from v2.4.5 can't be upgraded straight to 3.0. Delete it or migrate through v2.6 first.standardrbwas already broken on Ruby 3.3 before this change (racc/parserLoadError from the oldstandard ~> 1.27). This PR doesn't fix it.