Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
View all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
openclaw
rfcs
Repository navigation
Code
Issues
1
(1)
Pull requests
27
(27)
Actions
Projects
Security and quality
Insights
More
items
All pull requests
Labels
38
(38)
Milestones
0
(0)
New pull request
Search pull requests
is
:
pr
state
:
open
is:pr state:open
Clear filter
Search
Pull requests
Open
27
(27)
Closed
49
(49)
Author
Label
Projects
Milestones
Reviews
Assignee
Sort by
Newest
descending
Sort…
Sort by Newest descending
More items
Comfortable display density
Compact display density
fix: keep comment commands out of the item concurrency group
P2
proof: sufficient
rating: 🦐 gold shrimp
#77
·
SebTardif
opened
Oct 4, 2026
·
·
4
docs(rfc): propose Cloud Run Hosting and Cloud Run Sandboxes
merge-risk: 🚨 availability
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: 📣 needs proof
#76
·
ryanpei
opened
Sep 28, 2026
·
·
12
docs(rfc): propose external-supervisor operator guidance
P3
rating: 🧂 unranked krab
status: 📣 needs proof
#75
·
paulcam206
opened
Sep 22, 2026
·
·
6
docs: propose guest foreground work and restart notices
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#74
·
vincentkoc
opened
Sep 22, 2026
Member
·
·
4
docs: propose host-owned process execution authorization
merge-risk: 🚨 compatibility
P2
rating: 🧂 unranked krab
status: 📣 needs proof
#73
·
beenhero
opened
Sep 15, 2026
·
·
2
docs: make PR descriptions plain-language first
P3
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#72
·
roboclaw-bot
opened
Sep 12, 2026
·
·
2
docs: propose persistent Agent runtime lifecycle
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦐 gold shrimp
#71
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose service-owned work authority
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#70
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose workload identity and bounded enforcement
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦐 gold shrimp
#69
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose credential lifecycle and GitHub App access
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦐 gold shrimp
#68
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose a community visual identity and typography direction
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦐 gold shrimp
status: 👀 ready for maintainer look
#67
·
sergiopesch
opened
Sep 8, 2026
·
·
2
docs: propose plugin update availability
P3
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#66
·
ekinnee
opened
Sep 6, 2026
·
·
3
docs: propose demand-driven session sidebar collections
feature: ✨ showcase
P3
rating: 🧂 unranked krab
status: 📣 needs proof
#64
·
clawsweeper
opened
Aug 23, 2026
·
·
2
docs: propose gateway containment via Windows Isolation Sessions
merge-risk: 🚨 security-boundary
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#61
·
paulcam206
opened
Aug 18, 2026
·
·
5
docs: propose Claw composition evidence RFC
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#60
·
momothemage
opened
Aug 5, 2026
·
·
1
RFC 0029: External Automation Deadlines and Schedule-Only Occurrences
P3
rating: 🧂 unranked krab
status: 📣 needs proof
#59
·
omarshahine
opened
Aug 4, 2026
Contributor
·
·
1
docs: propose OpenClaw MSIX packaging for Windows
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#58
·
xlinush
opened
Aug 4, 2026
·
·
11
RFC 0020: OpenShell Worker Provider and Credential-Brokered Session Sandboxes
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#55
·
sallyom
opened
Jul 31, 2026
·
·
1
RFC 0027: Simplified Technical English for OpenClaw documentation
P3
rating: 🧂 unranked krab
status: 📣 needs proof
#53
·
jjjhenriksen
opened
Jul 29, 2026
·
·
2
RFC: Remote Agent Harness Bridge and Event Protocol
feature: ✨ showcase
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#31
·
efpiva
opened
Jul 7, 2026
·
·
5
RFC 0010: ACL-based memory partitioning and cross-user access
feature: ✨ showcase
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: 👀 ready for maintainer look
#30
·
galiniliev
opened
Jul 7, 2026
·
·
1
RFC 0009: Iroh Gateway transport
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#23
·
bjesuiter
opened
Jun 20, 2026
·
·
1
docs: add Agent Profiles RFC
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#18
·
vincentkoc
opened
Jun 17, 2026
Member
·
·
2
RFC 0012: Gateway-Independent OpenClaw Core
feature: ✨ showcase
P2
rating: 🦞 diamond lobster
status: 👀 ready for maintainer look
#17
·
fuller-stack-dev
opened
Jun 15, 2026
Member
·
·
1
RFC 0015: normalized provider→channel stream grammar
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#16
·
Marvinthebored
opened
Jun 15, 2026
·
·
1
3
Previous
1
2
Next
You can’t perform that action at this time.