Skip to content

DB creation failed in Telegraf logs #13

Description

@jpcapone

I am modifying the telegraf.conf file to point to the influx db and I get the error below:

This is when i point to the ip of the influx db container:

[outputs.influxdb] When writing to [http://172.18.0.2:8086]: database "vmware" creation failed: Post "http://172.18.0.2:8086/query": dial tcp 172.18.0.2:8086: connect: connection refused
2023-01-02T23:16:33Z E! [outputs.influxdb] E! [outputs.influxdb] Failed to write metric (will be dropped: 401 Unauthorized):

This is when i point to the ip of the docker host:

[outputs.influxdb] When writing to [http://10.229.181.68:8086]: database "vmware" creation failed: Post "http://10.229.181.68:8086/query": read tcp 172.18.0.4:60732->10.229.181.68:8086: read: connection reset by peer
2023-01-02T23:17:27Z E! [outputs.influxdb] E! [outputs.influxdb] Failed to write metric (will be dropped: 401 Unauthorized): 

Any suggestions would be greatly appreciated.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions