You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Chris Hansen edited this page May 2, 2018
·
2 revisions
In order to diagnose server initialization and non-parsing failures the fortls server can be run in a standalone debug mode. If you encounter errors during initialization that are not related to parsing follow the instructions below to help identify the cause/type of the error. Please include this output when submitting bugs related to server initialization failures.
Note: Debug information should not contain any subroutine/function contents. However, if the code you are working with is proprietary you may want to verify the output is clean before adding it to a public issue.
Running the server in debug mode
The server can be initialized for a given root directory in debug mode using the command below (if you installed FORTRAN Language Server using pip).